import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S*).*\\[(.*)\\]\\s\"(\\S*)\\s(\\S*)\\s([^\"]*)\"\\s(\\S*)\\s(\\S*)\\s\"([^\"]*)\"\\s\"\\\\?\"?([^\"]*)\\\\?\"?\"$";
final String string = "212.129.26.161 - - [25/Sep/2015:00:17:20 +0200] \"GET /wp/feed/ HTTP/1.1\" 200 11736 \"-\" \"Tiny Tiny RSS/1.15.3 (http://tt-rss.org/)\"\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}