// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\+\d{3}\s?)?\(?6\d{2}\)?[\s-]*\d{2}[\s-]*\d{2}[\s-]*\d{2}$").unwrap();
let string = "+224 664 36 07 29
+224(664) 36 07 29
(664)36 07 29
+224664360729
664 36 07 29
664-36-07-29
66436
(664)
\\(?\\d{3}\\)?[\\s.-]\\d{3}[\\s.-]\\d{4}$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}