$re = '/^(\+\d{3}\s?)?\(?6\d{2}\)?[\s-]*\d{2}[\s-]*\d{2}[\s-]*\d{2}$/m';
$str = '+224 664 36 07 29
+224(664) 36 07 29
(664)36 07 29
+224664360729
664 36 07 29
664-36-07-29
66436
(664)
\\(?\\d{3}\\)?[\\s.-]\\d{3}[\\s.-]\\d{4}$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);