#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+\d{3}\s?)?\(?6\d{2}\)?[\s-]*\d{2}[\s-]*\d{2}[\s-]*\d{2}$"
Local $sString = "+224 664 36 07 29" & @CRLF & _
"+224(664) 36 07 29" & @CRLF & _
"(664)36 07 29" & @CRLF & _
"+224664360729" & @CRLF & _
"664 36 07 29" & @CRLF & _
"664-36-07-29" & @CRLF & _
"" & @CRLF & _
"66436" & @CRLF & _
"(664)" & @CRLF & _
"\(?\d{3}\)?[\s.-]\d{3}[\s.-]\d{4}$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")