const regex = /^(\+\d{3}\s?)?\(?6\d{2}\)?[\s-]*\d{2}[\s-]*\d{2}[\s-]*\d{2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+\\d{3}\\s?)?\\(?6\\d{2}\\)?[\\s-]*\\d{2}[\\s-]*\\d{2}[\\s-]*\\d{2}$', 'gm')
const str = `+224 664 36 07 29
+224(664) 36 07 29
(664)36 07 29
+224664360729
664 36 07 29
664-36-07-29
66436
(664)
\\(?\\d{3}\\)?[\\s.-]\\d{3}[\\s.-]\\d{4}\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}