using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\+\d{3}\s?)?\(?6\d{2}\)?[\s-]*\d{2}[\s-]*\d{2}[\s-]*\d{2}$";
string input = @"+224 664 36 07 29
+224(664) 36 07 29
(664)36 07 29
+224664360729
664 36 07 29
664-36-07-29
66436
(664)
\(?\d{3}\)?[\s.-]\d{3}[\s.-]\d{4}$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}