package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\+\d{3}\s?)?\(?6\d{2}\)?[\s-]*\d{2}[\s-]*\d{2}[\s-]*\d{2}$`)
var str = `+224 664 36 07 29
+224(664) 36 07 29
(664)36 07 29
+224664360729
664 36 07 29
664-36-07-29
66436
(664)
\(?\d{3}\)?[\s.-]\d{3}[\s.-]\d{4}$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}