use strict;
my $str = '+224 664 36 07 29
+224(664) 36 07 29
(664)36 07 29
+224664360729
664 36 07 29
664-36-07-29
66436
(664)
\\(?\\d{3}\\)?[\\s.-]\\d{3}[\\s.-]\\d{4}$';
my $regex = qr/^(\+\d{3}\s?)?\(?6\d{2}\)?[\s-]*\d{2}[\s-]*\d{2}[\s-]*\d{2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}