// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+[1-9][\d]{8,14}(;ext=[\d]{3,6})?$").unwrap();
let string = "+14160001234
+18001234567
+442012345678
+14160007890;ext=12345
# Max Digits is 15
+123456789012345
+123456789012345;ext=123456
+1234567890123456
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}