$re = '/^\+[1-9][\d]{8,14}(;ext=[\d]{3,6})?$/m';
$str = '+14160001234
+18001234567
+442012345678
+14160007890;ext=12345
# Max Digits is 15
+123456789012345
+123456789012345;ext=123456
+1234567890123456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);