import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+[1-9][\\d]{8,14}(;ext=[\\d]{3,6})?$";
final String string = "+14160001234\n\n"
+ "+18001234567\n\n"
+ "+442012345678\n\n"
+ "+14160007890;ext=12345\n"
+ "# Max Digits is 15\n"
+ "+123456789012345\n"
+ "+123456789012345;ext=123456\n"
+ "+1234567890123456\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}