#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+[1-9][\d]{8,14}(;ext=[\d]{3,6})?$"
Local $sString = "+14160001234" & @CRLF & _
"" & @CRLF & _
"+18001234567" & @CRLF & _
"" & @CRLF & _
"+442012345678" & @CRLF & _
"" & @CRLF & _
"+14160007890;ext=12345" & @CRLF & _
"# Max Digits is 15" & @CRLF & _
"+123456789012345" & @CRLF & _
"+123456789012345;ext=123456" & @CRLF & _
"+1234567890123456" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")