using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+[1-9][\d]{8,14}(;ext=[\d]{3,6})?$";
string input = @"+14160001234
+18001234567
+442012345678
+14160007890;ext=12345
# Max Digits is 15
+123456789012345
+123456789012345;ext=123456
+1234567890123456
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}