const regex = /^\+[1-9][\d]{8,14}(;ext=[\d]{3,6})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+[1-9][\\d]{8,14}(;ext=[\\d]{3,6})?$', 'gm')
const str = `+14160001234
+18001234567
+442012345678
+14160007890;ext=12345
# Max Digits is 15
+123456789012345
+123456789012345;ext=123456
+1234567890123456
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}