package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+[1-9][\d]{8,14}(;ext=[\d]{3,6})?$`)
var str = `+14160001234
+18001234567
+442012345678
+14160007890;ext=12345
# Max Digits is 15
+123456789012345
+123456789012345;ext=123456
+1234567890123456
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}