// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[0]\d{10}$)|(^[\+]?[234]\d{12}$)").unwrap();
let string = "08062242801
+2340862242901
6754
2340862242901
+2348062242901";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}