package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[0]\d{10}$)|(^[\+]?[234]\d{12}$)`)
var str = `08062242801
+2340862242901
6754
2340862242901
+2348062242901`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}