const regex = /(^[0]\d{10}$)|(^[\+]?[234]\d{12}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[0]\\d{10}$)|(^[\\+]?[234]\\d{12}$)', 'gm')
const str = `08062242801
+2340862242901
6754
2340862242901
+2348062242901`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}