re = /(^[0]\d{10}$)|(^[\+]?[234]\d{12}$)/m
str = '08062242801
+2340862242901
6754
2340862242901
+2348062242901'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end