$re = '/(^[0]\d{10}$)|(^[\+]?[234]\d{12}$)/m';
$str = '08062242801
+2340862242901
6754
2340862242901
+2348062242901';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);