using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[0]\d{10}$)|(^[\+]?[234]\d{12}$)";
string input = @"08062242801
+2340862242901
6754
2340862242901
+2348062242901";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}