#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[0]\d{10}$)|(^[\+]?[234]\d{12}$)"
Local $sString = "08062242801" & @CRLF & _
"+2340862242901" & @CRLF & _
"6754" & @CRLF & _
"2340862242901" & @CRLF & _
"+2348062242901"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")