import Foundation
let pattern = #"(Franklin,\s|franklin,\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Franklin, can you please do this or this for me?
franklin, can you please do this or this for me?
Franklin, can you please remind me to do X at 0:00pm?
franklin, can you please remind me to do X at 0:00pm?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)