using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Franklin,\s|franklin,\s)";
string input = @"Franklin, can you please do this or this for me?
franklin, can you please do this or this for me?
Franklin, can you please remind me to do X at 0:00pm?
franklin, can you please remind me to do X at 0:00pm?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}