import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Franklin,\\s|franklin,\\s)";
final String string = "Franklin, can you please do this or this for me?\n"
+ "franklin, can you please do this or this for me?\n\n"
+ "Franklin, can you please remind me to do X at 0:00pm?\n"
+ "franklin, can you please remind me to do X at 0:00pm?";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}