// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(Franklin,\s|franklin,\s)").unwrap();
let string = "Franklin, can you please do this or this for me?
franklin, can you please do this or this for me?
Franklin, can you please remind me to do X at 0:00pm?
franklin, can you please remind me to do X at 0:00pm?";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}