const regex = new RegExp('(Franklin,\\s|franklin,\\s)', 'g')
const str = `Franklin, can you please do this or this for me?
franklin, can you please do this or this for me?
Franklin, can you please remind me to do X at 0:00pm?
franklin, can you please remind me to do X at 0:00pm?`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}