re = /(Franklin,\s|franklin,\s)/
str = 'Franklin, can you please do this or this for me?
franklin, can you please do this or this for me?
Franklin, can you please remind me to do X at 0:00pm?
franklin, can you please remind me to do X at 0:00pm?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end