package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Franklin,\s|franklin,\s)`)
var str = `Franklin, can you please do this or this for me?
franklin, can you please do this or this for me?
Franklin, can you please remind me to do X at 0:00pm?
franklin, can you please remind me to do X at 0:00pm?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}