import Foundation
let pattern = #"({\n\s*)(?:[^}{]*)(\n\s*{)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
{
"origin" "887 -100 128"
"texture" "{gargstomp"
"classname" "infodecal"
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)