$re = '/({\n\s*)(?:[^}{]*)(\n\s*{)/im';
$str = '
{
"origin" "887 -100 128"
"texture" "{gargstomp"
"classname" "infodecal"
}
';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;