// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)({\n\s*)(?:[^}{]*)(\n\s*{)").unwrap();
let string = "
{
\"origin\" \"887 -100 128\"
\"texture\" \"{gargstomp\"
\"classname\" \"infodecal\"
}
";
let substitution = "\\1 \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}