re = /({\n\s*)(?:[^}{]*)(\n\s*{)/im
str = '
{
"origin" "887 -100 128"
"texture" "{gargstomp"
"classname" "infodecal"
}
'
subst = '\\1 \\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result