const regex = /({\n\s*)(?:[^}{]*)(\n\s*{)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({\\n\\s*)(?:[^}{]*)(\\n\\s*{)', 'gim')
const str = `
{
"origin" "887 -100 128"
"texture" "{gargstomp"
"classname" "infodecal"
}
`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);