package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)({\n\s*)(?:[^}{]*)(\n\s*{)`)
var str = `
{
"origin" "887 -100 128"
"texture" "{gargstomp"
"classname" "infodecal"
}
`
var substitution = "\1 \2"
fmt.Println(re.ReplaceAllString(str, substitution))
}