import Foundation
let pattern = #"^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(\S).{6,14}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)