# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(\S).{6,14}$//gm;t' <<< "qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
"