$re = '/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(\S).{6,14}$/m';
$str = 'qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;