#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(\S).{6,14}$"
Local $sString = "qwerty1" & @CRLF & _
"QWERTY1q" & @CRLF & _
"qwERTy" & @CRLF & _
"QWERTY1" & @CRLF & _
"QWER TY1q" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)