use strict;
my $str = 'qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
';
my $regex = qr/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(\S).{6,14}$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";