const regex = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(\S).{6,14}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\d)(?=.*[a-z])(?=.*[A-Z])(\\S).{6,14}$', 'gm')
const str = `qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);