using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(\S).{6,14}$";
string substitution = @"";
string input = @"qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}