import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\nREM\\s*";
final String string = "Erzeugt einen textlichen Hinweis für den Fall, dass eine sekundäre Mengenangabe\n"
+ "REM durchgeführt wurde und dabei die zulässigen Toleranzen überschritten wurden\n"
+ "REM [task=29261]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}