import Foundation
let pattern = #"\s+|^((1[0-9]{1,3})|(20[0-1][0-2])|(200[0-9]))\/((0[0-9])|[0-9]|[1][0-2])\/(([0-2][0-9])|(30)) (([0-1][0-9])|([2][0-4])):([0-6][0-9])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
1995/12/01 12:12
1012/12/02 12:34
4012/12/02 12:34
3012/12/02 12:34
2013/12/02 12:34
2007/13/02 12:34
2007/12/02 12:34
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)