// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\s+|^((1[0-9]{1,3})|(20[0-1][0-2])|(200[0-9]))\/((0[0-9])|[0-9]|[1][0-2])\/(([0-2][0-9])|(30)) (([0-1][0-9])|([2][0-4])):([0-6][0-9])").unwrap();
let string = "1995/12/01 12:12
1012/12/02 12:34
4012/12/02 12:34
3012/12/02 12:34
2013/12/02 12:34
2007/13/02 12:34
2007/12/02 12:34";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}