package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\s+|^((1[0-9]{1,3})|(20[0-1][0-2])|(200[0-9]))\/((0[0-9])|[0-9]|[1][0-2])\/(([0-2][0-9])|(30)) (([0-1][0-9])|([2][0-4])):([0-6][0-9])`)
var str = `1995/12/01 12:12
1012/12/02 12:34
4012/12/02 12:34
3012/12/02 12:34
2013/12/02 12:34
2007/13/02 12:34
2007/12/02 12:34`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}