using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s+|^((1[0-9]{1,3})|(20[0-1][0-2])|(200[0-9]))\/((0[0-9])|[0-9]|[1][0-2])\/(([0-2][0-9])|(30)) (([0-1][0-9])|([2][0-4])):([0-6][0-9])";
string input = @"1995/12/01 12:12
1012/12/02 12:34
4012/12/02 12:34
3012/12/02 12:34
2013/12/02 12:34
2007/13/02 12:34
2007/12/02 12:34";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}