import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s+|^((1[0-9]{1,3})|(20[0-1][0-2])|(200[0-9]))\\/((0[0-9])|[0-9]|[1][0-2])\\/(([0-2][0-9])|(30)) (([0-1][0-9])|([2][0-4])):([0-6][0-9])";
final String string = "1995/12/01 12:12\n"
+ "1012/12/02 12:34\n"
+ "4012/12/02 12:34\n"
+ "3012/12/02 12:34\n"
+ "2013/12/02 12:34\n"
+ "2007/13/02 12:34\n"
+ "2007/12/02 12:34";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}