$re = '/\s+|^((1[0-9]{1,3})|(20[0-1][0-2])|(200[0-9]))\/((0[0-9])|[0-9]|[1][0-2])\/(([0-2][0-9])|(30)) (([0-1][0-9])|([2][0-4])):([0-6][0-9])/mi';
$str = '1995/12/01 12:12
1012/12/02 12:34
4012/12/02 12:34
3012/12/02 12:34
2013/12/02 12:34
2007/13/02 12:34
2007/12/02 12:34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);