// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https://mega\.nz/((folder|file)/([^#]+)#(.+)|#(F?)!([^!]+)!(.+))").unwrap();
let string = "https://mega.nz/folder/xxxxxxx#zzzzzzzzzzzzzzzzzzzzzz
https://mega.nz/#F!xxxxxxx!zzzzzzzzzzzzzzzzzzzzzz
https://mega.nz/file/yyyyyyy#bbbbbbbbbbbbbbbbbbb
https://mega.nz/#!yyyyyyy!bbbbbbbbbbbbbbbbbbb";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}